| # |
| # Copyright 2022 Google LLC |
| # |
| # This program is free software; you can redistribute it and/or |
| # modify it under the terms of the GNU General Public License |
| # version 2 as published by the Free Software Foundation. |
| # |
| # This program is distributed in the hope that it will be useful, |
| # but WITHOUT ANY WARRANTY; without even the implied warranty of |
| # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
| # GNU General Public License for more details. |
| # |
| # shellcheck disable=SC2034,SC2154 |
| |
| EAPI=7 |
| |
| # IMPORTANT: When updating the kernel, do not delete patches named with |
| # FEATURE-PATCH in them without verifying that the functionality the patch adds |
| # is still present (tested and confirmed) |
| |
| # https://cos.googlesource.com/third_party/kernel/+/refs/heads/main-R105-cos-5.15 |
| # https://cos-review.git.corp.google.com/c/third_party/kernel/+/74315 |
| CROS_WORKON_COMMIT="1edb19e8e583706736344f51952ba2a4c4c01397" |
| CROS_WORKON_TREE="185f4472f39adf3448f565c3fc770a596759053d" |
| CROS_WORKON_REPO="https://cos.googlesource.com" |
| CROS_WORKON_PROJECT="third_party/kernel" |
| CROS_WORKON_LOCALNAME="kernel/v5.15" |
| |
| # This must be inherited *after* EGIT/CROS_WORKON variables defined |
| inherit cros-workon gmec-kernel |
| |
| STRIP_MASK+=" /usr/src/${P}/build/vmlinux" |
| STRIP_MASK+=" *.ko" |
| |
| DESCRIPTION="COS Linux Kernel 5.15" |
| HOMEPAGE="https://cloud.google.com/container-optimized-os" |
| KEYWORDS="*" |
| IUSE="module_sign lockdown gpu" |
| |
| COS_KERNEL_X509_GENKEY="${FILESDIR}/x509.genkey" |
| COS_KERNEL_ROOT_CERT="${FILESDIR}/lakitu_root_cert.pem" |
| COS_KERNEL_GPU_ROOT_CERT="${FILESDIR}/lakitu_gpu_root_cert.pem" |
| GMEC_KERNEL_SUFFIX="" |
| |
| src_configure() { |
| gmec-kernel_src_configure |
| } |
| |
| src_prepare() { |
| default |
| cos-kernel_src_prepare |
| } |
| |
| src_install() { |
| gmec-kernel_src_install |
| } |
| |
| # Change the following (commented out) number to the next prime number |
| # when you change base.config. This workaround will force the |
| # ChromeOS CQ to uprev sys-kernel/kernel-5_15 ebuild and pick up the |
| # configuration changes. In absence of this workaround the config changes |
| # would not be picked up unless there was a code change in kernel source tree. |
| # |
| # NOTE: There's nothing magic keeping this number prime but you just need to |
| # make _any_ change to this file. ...so why not keep it prime? |
| # |
| # The coolest prime number is: 17 |