| # |
| # Copyright (2023) Google LLC |
| # |
| # This program is free software; you can redistribute it and/or |
| # modify it under the terms of the GNU General Public License |
| # version 2 as published by the Free Software Foundation. |
| # |
| # This program is distributed in the hope that it will be useful, |
| # but WITHOUT ANY WARRANTY; without even the implied warranty of |
| # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
| # GNU General Public License for more details. |
| # |
| |
| EAPI="7" |
| |
| inherit systemd |
| |
| DESCRIPTION="Board-specific packages for EdgeOS" |
| HOMEPAGE="http://src.chromium.org" |
| SRC_URI="" |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="-* amd64 arm64 arm" |
| |
| RDEPEND=" |
| sys-apps/baselayout |
| " |
| |
| S="${WORKDIR}" |
| |
| src_install() { |
| insinto /etc |
| doins "${FILESDIR}"/os-release |
| doins "${FILESDIR}"/nsswitch.conf |
| |
| insinto /etc/modprobe.d |
| doins "${FILESDIR}"/edgeos_aliases.conf |
| |
| insinto /etc/profile.d/ |
| doins "${FILESDIR}"/editor.sh |
| doins "${FILESDIR}"/prompt-command.sh |
| |
| systemd_dounit "${FILESDIR}"/report-system-info.service |
| systemd_enable_service multi-user.target report-system-info.service |
| |
| insinto "$(systemd_get_systemunitdir)"/systemd-fsck@.service.d |
| doins "${FILESDIR}"/fsck-log-to-serial-console.conf |
| |
| # Nvidia drivers are mounted here at runtime |
| keepdir /usr/share/nvidia |
| } |