blob: 77c9471dbfd044a6ef00bceae139418a4408fcfe [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Use of this source code is governed by a BSD-style license that can be
# found in the LICENSE file.
EAPI=5
DESCRIPTION="CoreOS Toolbox Utility"
HOMEPAGE="https://github.com/coreos/toolbox"
EGIT_REPO_URI="https://chromium.googlesource.com/external/github.com/coreos/toolbox.git"
EGIT_COMMIT="a2767a0013c409a2381f7cdd4e31000b5fcded7e"
EGIT_MASTER="main"
inherit eutils git-2 systemd
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
IUSE=""
DEPEND=""
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/0001-Added-containerd-support.patch
}
src_install() {
dobin "${S}"/toolbox
systemd_dounit "${FILESDIR}"/var-lib-toolbox.mount
systemd_dounit "${FILESDIR}"/var-lib-toolbox-remount.service
systemd_enable_service local-fs.target var-lib-toolbox.mount
}