blob: a064753579a776af42c52fcb2139f3a50b8c973e [file] [log] [blame]
#
# Copyright 2021 Google LLC
#
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License
# version 2 as published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
EAPI=7
inherit systemd create-overlay
DESCRIPTION="A daemon to control runC"
HOMEPAGE="https://containerd.io/"
VERSION=1.7.1-gke.0
SRC_URI="gs://chromeos-localmirror-private/distfiles/cri-containerd-${VERSION}-linux-${ARCH}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="*"
RESTRICT="mirror"
IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
S="${WORKDIR}"
DEPEND="
btrfs? ( sys-fs/btrfs-progs )
seccomp? ( sys-libs/libseccomp )
"
# lakitu: RDEPEND on sys-apps/systemd because of the dependency on
# containerd.service.
RDEPEND="
${DEPEND}
>=app-containers/runc-1.0.0
sys-apps/systemd
"
src_install() {
dobin usr/local/bin/{containerd,containerd-shim,containerd-shim-runc-v1,containerd-shim-runc-v2,ctr}
systemd_dounit "${FILESDIR}"/containerd.service
systemd_enable_service multi-user.target containerd.service
# needed for containerd certs (b/183808542)
create_stateful_overlay /etc/ssl/certs - - -
}