blob: 577f58d60df0e32fbd4293f06b7377515374b90f [file] [log] [blame]
# Copyright 2018 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
CROS_WORKON_COMMIT="c142078820d0707858873cedb290a78d36f531af"
CROS_WORKON_TREE=("eec5ce9cfadd268344b02efdbec7465fbc391a9e" "0468cec41388f85dd89a5eb66bef35fcf7a5c524" "e7dba8c91c1f3257c34d4a7ffff0ea2537aeb6bb")
CROS_WORKON_PROJECT="chromiumos/platform2"
CROS_WORKON_LOCALNAME="platform2"
CROS_WORKON_OUTOFTREE_BUILD=1
CROS_WORKON_SUBTREE="common-mk chromeos-common-script .gn"
PLATFORM_SUBDIR="chromeos-common-script"
inherit cros-workon platform
DESCRIPTION="Chrome OS storage info tools"
HOMEPAGE="https://chromium.googlesource.com/chromiumos/platform2/+/master/chromeos-common-script/"
SRC_URI=""
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="*"
IUSE="direncryption"
DEPEND=""
RDEPEND="!<chromeos-base/chromeos-installer-0.0.3"
src_install() {
insinto /usr/share/misc
doins share/chromeos-common.sh
if use direncryption; then
sed -i '/local direncryption_enabled=/s/false/true/' \
"${D}/usr/share/misc/chromeos-common.sh" ||
die "Can not set directory encryption in common library"
fi
}