blob: e5a8ee943b22ddad957d1a3c4d0168db098d53d9 [file] [log] [blame]
# Copyright 2017 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit udev
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* arm64 arm"
IUSE="cheets"
S="${WORKDIR}"
RDEPEND="
"
DEPEND="${RDEPEND}"
src_install() {
# Override default CPU clock speed governor.
insinto "/etc"
doins "${FILESDIR}/cpufreq.conf"
# Install cpuset adjustments.
insinto "/etc/init"
doins "${FILESDIR}/platform-cpusets.conf"
if use cheets; then
insinto "/opt/google/containers/android/vendor/etc/init/"
doins "${FILESDIR}/init.cpusets.rc"
fi
# udev rules for codecs
insinto /etc/init
doins "${FILESDIR}/udev-trigger-codec.conf"
udev_dorules "${FILESDIR}/50-media.rules"
# TODO: may need some tweaks to cpusets for big.LITTLE like
# baseboard-gru had.
}