| # Copyright 2016 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=5 |
| CROS_WORKON_COMMIT="29e44dcd3f7ced6c1746a51a2cf139b75eb0b725" |
| CROS_WORKON_TREE="9b7142362ae5b99e4ebf20331ffc5cdf515b1280" |
| CROS_WORKON_PROJECT="chromiumos/third_party/kernel" |
| CROS_WORKON_LOCALNAME="kernel/v4.4" |
| |
| CHROMEOS_KERNEL_CONFIG="${FILESDIR}/lakitu_kernel_config_4_4" |
| |
| # This must be inherited *after* EGIT/CROS_WORKON variables defined |
| inherit cros-workon cros-kernel2 osreleased |
| |
| STRIP_MASK+=" /usr/src/${P}/build/vmlinux" |
| |
| DESCRIPTION="Chromium OS Linux Kernel 4.4" |
| HOMEPAGE="https://www.chromium.org/chromium-os/chromiumos-design-docs/chromium-os-kernel" |
| KEYWORDS="*" |
| |
| src_install() { |
| cros-kernel2_src_install |
| |
| # VCSID variable is unconditionally set by the cros-workon eclass, and |
| # is in the form of "<ebuild_revision>-<sha1>". |
| do_osrelease_field "KERNEL_COMMIT_ID" "${VCSID##*-}" |
| } |
| |
| # Change the following (commented out) number to the next prime number |
| # when you change lakitu_kernel_config_4_4. This workaround will force the |
| # ChromeOS CQ to uprev sys-kernel/lakitu-kernel-4_4 ebuild and pick up the |
| # configuration changes. In absence of this workaround the config changes |
| # would not be picked up unless there was a code change in kernel source tree. |
| # |
| # NOTE: There's nothing magic keeping this number prime but you just need to |
| # make _any_ change to this file. ...so why not keep it prime? |
| # |
| # The coolest prime number is: 3 |