blob: 0d71d6c4ce19af1d65dcc7c72a8653844aa89b5d [file] [log] [blame]
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit fcaps toolchain-funcs
DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
SRC_URI="http://www.habets.pp.se/synscan/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="*"
IUSE="test"
RESTRICT="!test? ( test )"
CDEPEND="
net-libs/libpcap
net-libs/libnet:1.1
"
DEPEND="
${CDEPEND}
test? ( dev-libs/check )
"
RDEPEND="
${CDEPEND}
!net-misc/iputils[arping(+)]
"
FILECAPS=( cap_net_raw "${EROOT}"/usr/sbin/arping )
PATCHES=( "${FILESDIR}/arping-tests.patch" )
src_configure() {
# Some libs use $(AR) rather than libtool to build #444282
tc-export CC
./configure \
CPPFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}" \
--prefix="${EPREFIX}/usr"
}