| # Copyright 2016 The Chromium OS Authors. All rights reserved. |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=4 |
| |
| inherit appid cros-audio-configs udev |
| |
| DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies |
| or portage actions." |
| |
| LICENSE="BSD-Google" |
| SLOT="0" |
| KEYWORDS="-* amd64 x86" |
| IUSE="" |
| S="${WORKDIR}" |
| |
| # Add dependencies on other ebuilds from within this board overlay |
| RDEPEND=" |
| chromeos-base/chromeos-bsp-baseboard-glados |
| chromeos-base/ec-utils |
| sys-kernel/linux-firmware |
| media-gfx/ply-image |
| " |
| DEPEND="${RDEPEND}" |
| |
| src_install() { |
| doappid "{B00DD0BC-D2C9-BAB4-E66C-81AE3F5A7CED}" "CHROMEBOOK" |
| |
| udev_dorules "${FILESDIR}/92-powerd-overrides.rules" |
| # Install audio config files |
| local audio_config_dir="${FILESDIR}/audio-config" |
| install_audio_configs cave "${audio_config_dir}" |
| |
| # Install platform specific config files for power_manager. |
| insinto "/usr/share/power_manager/board_specific" |
| doins "${FILESDIR}"/powerd_prefs/* |
| |
| # Install Bluetooth ID override. |
| insinto "/etc/bluetooth" |
| doins "${FILESDIR}/main.conf" |
| } |