blob: 7fd09bf0c0ca6df84fba6f82ad4c350e1a5a4b18 [file] [log] [blame]
# Copyright 2020 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CROS_WORKON_COMMIT="3a01873e59ec25ecb10d1b07ff9816e69f3bbfee"
CROS_WORKON_TREE="8ce164efd78fcb4a68e898d8c92c7579657a49b1"
inherit cros-workon udev
# This ebuild only cares about its own FILESDIR and ebuild file, so it tracks
# the canonical empty project.
CROS_WORKON_PROJECT="chromiumos/infra/build/empty-project"
CROS_WORKON_LOCALNAME="empty-project"
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* arm64 arm"
IUSE="cheets"
RDEPEND="
net-misc/rmtfs
"
DEPEND="${RDEPEND}"
src_install() {
# Override default CPU clock speed governor.
insinto "/etc"
doins "${FILESDIR}/cpufreq.conf"
# Install cpuset adjustments.
insinto "/etc/init"
doins "${FILESDIR}/platform-cpusets.conf"
if use cheets; then
insinto "/opt/google/containers/android/vendor/etc/init/"
doins "${FILESDIR}/init.cpusets.rc"
fi
# udev rules for codecs
insinto /etc/init
doins "${FILESDIR}/udev-trigger-codec.conf"
udev_dorules "${FILESDIR}/50-media.rules"
# Install modem FSG verification init script
insinto "/etc/init"
doins "${FILESDIR}/verify_fsg.conf"
exeinto /usr/share/cros/init
doexe "${FILESDIR}/verify_fsg.sh"
}