blob: fbaba6f56eb21e302880199ef1d108d07163e11e [file] [log] [blame]
# Copyright (c) 2014 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Winky bsp (meta package to pull in driver/tool deps)"
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE=""
S="${WORKDIR}"
RDEPEND="
chromeos-base/chromeos-touch-config-winky
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{4B8B5979-526A-48D6-B6EB-D72680471AAD}" "CHROMEBOOK"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Install audio config files.
local audio_config_dir="${FILESDIR}/audio-config"
install_audio_configs swanky "${audio_config_dir}"
}