blob: 87ba5e6c66bc51a9f7ea5674411195bfe5d931f9 [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE="kernelnext"
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{74A5A9DD-1B51-4602-A7FA-751B804627A0}" "CHROMEBOOK"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Install audio configs.
if use kernelnext; then
local audio_config_dir="${FILESDIR}/kernelnext-audio-config"
else
local audio_config_dir="${FILESDIR}/audio-config"
fi
install_audio_configs wizpig "${audio_config_dir}"
}