blob: b55ae455926c6c02afab598fedec5e1e777827ab [file] [log] [blame]
# Copyright 2015 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=4
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE="kernelnext"
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{196C49C7-152F-499B-9C64-F5B8A89E43A4}" "CHROMEBOOK"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Install audio configs.
if use kernelnext; then
local audio_config_dir="${FILESDIR}/kernelnext-audio-config"
else
local audio_config_dir="${FILESDIR}/audio-config"
fi
install_audio_configs edgar "${audio_config_dir}"
}