blob: d7372187348366354c5a42ff7665d7f16512bfc6 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit appid cros-audio-configs udev
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
S="${WORKDIR}"
IUSE="kefka-kernelnext"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-strago
"
DEPEND="${RDEPEND}"
src_install() {
if use kefka-kernelnext; then
doappid "{33D387DA-99F8-11E9-A838-7B9E2880DE80}" "CHROMEBOOK"
else
doappid "{2EDF7C6D-6586-D292-0B61-4A33B62E3BF6}" "CHROMEBOOK"
fi
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
# Install audio config files
local audio_config_dir="${FILESDIR}/audio-config"
install_audio_configs kefka "${audio_config_dir}"
# Install udev rules.
udev_dorules "${FILESDIR}"/udev-rules/*.rules
}