| # Copyright 1999-2022 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| inherit autotools |
| |
| DESCRIPTION="The Drive Trust Alliance Self Encrypting Drive Utility" |
| HOMEPAGE="https://github.com/Drive-Trust-Alliance/sedutil" |
| SRC_URI="https://github.com/Drive-Trust-Alliance/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" |
| |
| LICENSE="GPL-3+" |
| SLOT="0" |
| KEYWORDS="amd64 ~arm64 ~ppc64 x86" |
| |
| PATCHES=( |
| "${FILESDIR}"/0001-Shuffle-GetPassPhrase-.h-.cpp-in-makefile.am.patch |
| "${FILESDIR}"/0002-Add-securemode-password-setting.patch |
| "${FILESDIR}"/0003-Add-verifySIDPassword.patch |
| "${FILESDIR}"/0004-Add-newpassword-setting.patch |
| "${FILESDIR}"/0005-Fix-Enterprise-setSIDPassword.patch |
| ) |
| src_prepare() { |
| default |
| |
| # https://github.com/Drive-Trust-Alliance/sedutil/pull/49 |
| sed 's: -Werror: :g' \ |
| -i configure.ac \ |
| -i Makefile.am || die |
| eautoreconf |
| } |