blob: 8335ae2ca1fb49fce80d4092fe8eaffd008271e1 [file] [log] [blame]
# Copyright 2016 The Chromium OS Authors. All rights reserved.
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit appid cros-audio-configs
DESCRIPTION="Ebuild which pulls in any necessary ebuilds as dependencies
or portage actions."
LICENSE="BSD-Google"
SLOT="0"
KEYWORDS="-* amd64 x86"
IUSE="cave-kernelnext"
S="${WORKDIR}"
# Add dependencies on other ebuilds from within this board overlay
RDEPEND="
chromeos-base/chromeos-bsp-baseboard-glados
"
DEPEND="${RDEPEND}"
src_install() {
doappid "{B00DD0BC-D2C9-BAB4-E66C-81AE3F5A7CED}" "CHROMEBOOK"
# Install audio configs.
if use cave-kernelnext; then
local audio_config_dir="${FILESDIR}/kernelnext-audio-config"
else
local audio_config_dir="${FILESDIR}/audio-config"
fi
install_audio_configs cave "${audio_config_dir}"
# Install platform specific config files for power_manager.
insinto "/usr/share/power_manager/board_specific"
doins "${FILESDIR}"/powerd_prefs/*
}