| # Copyright 1999-2022 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=7 |
| |
| inherit flag-o-matic linux-info meson systemd udev |
| |
| DESCRIPTION="A performant, transport independent, multi-platform implementation of RFC3720" |
| HOMEPAGE="https://www.open-iscsi.com/" |
| SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz" |
| |
| LICENSE="GPL-2" |
| SLOT="0/0.2" |
| KEYWORDS="*" |
| IUSE="debug infiniband +tcp rdma systemd" |
| REQUIRED_USE="infiniband? ( rdma ) || ( rdma tcp )" |
| # Tries to write to /run/lock/iscsi etc |
| RESTRICT="test" |
| |
| DEPEND=" |
| dev-libs/openssl:= |
| sys-apps/kmod |
| sys-block/open-isns:= |
| sys-kernel/linux-headers |
| infiniband? ( sys-cluster/rdma-core ) |
| systemd? ( sys-apps/systemd:= ) |
| " |
| # lakitu: remove lsscsi utility as it is not used. |
| #sys-fs/lsscsi |
| RDEPEND=" |
| ${DEPEND} |
| sys-apps/util-linux |
| " |
| BDEPEND="virtual/pkgconfig" |
| |
| PATCHES=( |
| "${FILESDIR}"/${PN}-2.1.1-Makefiles.patch |
| ) |
| |
| pkg_setup() { |
| linux-info_pkg_setup |
| |
| if kernel_is -lt 2 6 16; then |
| die "Sorry, your kernel must be 2.6.16-rc5 or newer!" |
| fi |
| |
| # Needs to be done, as iscsid currently only starts, when having the iSCSI |
| # support loaded as module. Kernel builtin options don't work. See this for |
| # more information: |
| # https://groups.google.com/group/open-iscsi/browse_thread/thread/cc10498655b40507/fd6a4ba0c8e91966 |
| # If there's a new release, check whether this is still valid! |
| TCP_MODULES="SCSI_ISCSI_ATTRS ISCSI_TCP" |
| RDMA_MODULES="INFINIBAND_ISER" |
| INFINIBAND_MODULES="INFINIBAND_IPOIB INIBAND_USER_MAD INFINIBAND_USER_ACCESS" |
| CONFIG_CHECK_MODULES="tcp? ( ${TCP_MODULES} ) rdma? ( ${RDMA_MODULES} ) infiniband? ( ${INFINIBAND_MODULES} )" |
| if linux_config_exists; then |
| if use tcp; then |
| for module in ${TCP_MODULES}; do |
| linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)" |
| done |
| fi |
| if use infiniband; then |
| for module in ${INFINIBAND_MODULES}; do |
| linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)" |
| done |
| fi |
| if use rdma; then |
| for module in ${RDMA_MODULES}; do |
| linux_chkconfig_module ${module} || ewarn "${module} needs to be built as module (builtin doesn't work)"$ |
| done |
| fi |
| fi |
| } |
| |
| src_configure() { |
| use debug && append-cppflags -DDEBUG_TCP -DDEBUG_SCSI |
| |
| local emesonargs=( |
| -Dsystemddir="$(systemd_get_utildir)" |
| -Drulesdir="$(get_udevdir)"/rules.d |
| $(meson_use !systemd no_systemd) |
| ) |
| |
| meson_src_configure |
| } |
| |
| src_install() { |
| meson_src_install |
| |
| # Upstream make is not deterministic, per bug #601514 |
| rm -f "${ED}"/etc/initiatorname.iscsi |
| |
| docinto test/ |
| dodoc $(find test -maxdepth 1 -type f ! -name ".*") |
| |
| insinto /etc/iscsi |
| newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example |
| |
| newconfd "${FILESDIR}"/iscsid-conf.d iscsid |
| newinitd "${FILESDIR}"/iscsid-init.d iscsid |
| |
| |
| |
| # lakitu: don't keep any directories/files in var as emerge expects it |
| # to be empty. |
| #keepdir /var/db/iscsi |
| #fperms 700 /var/db/iscsi |
| fperms 600 /etc/iscsi/iscsid.conf |
| systemd_enable_service multi-user.target iscsid.service |
| |
| } |
| |
| pkg_postinst() { |
| in='/etc/iscsi/initiatorname.iscsi' |
| if [[ ! -f "${EROOT}${in}" ]] && [[ -f "${EROOT}${in}.example" ]] ; then |
| { |
| cat "${EROOT}${in}.example" |
| echo "# InitiatorName generated by ${CATEGORY}/${PF} at $(date -uR)" |
| echo "InitiatorName=$(${ROOT}/usr/sbin/iscsi-iname)" |
| } >> "${EROOT}${in}.tmp" && mv -f "${EROOT}${in}.tmp" "${EROOT}${in}" |
| fi |
| |
| udev_reload |
| } |