| # Copyright 1999-2020 Gentoo Authors |
| # Distributed under the terms of the GNU General Public License v2 |
| |
| EAPI=5 |
| |
| PYTHON_COMPAT=( python3_{6..8} pypy3 ) |
| |
| inherit distutils-r1 |
| |
| DESCRIPTION="Fast, simple object-to-object and broadcast signaling" |
| HOMEPAGE="https://pythonhosted.org/blinker/ https://pypi.org/project/blinker/" |
| SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz" |
| |
| LICENSE="MIT" |
| SLOT="0" |
| KEYWORDS="*" |
| IUSE="doc test" |
| RESTRICT="!test? ( test )" |
| |
| DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )" |
| |
| python_test() { |
| nosetests -v || die "Testing failed with ${EPYTHON}" |
| } |
| |
| python_install_all() { |
| use doc && HTML_DOCS=( docs/html/. ) |
| distutils-r1_python_install_all |
| } |