| # |
| # Copyright 2023 Google LLC |
| # |
| # This program is free software; you can redistribute it and/or |
| # modify it under the terms of the GNU General Public License |
| # version 2 as published by the Free Software Foundation. |
| # |
| # This program is distributed in the hope that it will be useful, |
| # but WITHOUT ANY WARRANTY; without even the implied warranty of |
| # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the |
| # GNU General Public License for more details. |
| # |
| |
| EAPI=7 |
| |
| DISTUTILS_USE_PEP517="setuptools" |
| PYTHON_COMPAT=( python3_{6..9} ) |
| |
| inherit distutils-r1 |
| |
| DESCRIPTION="Command line interface for testing internet bandwidth using speedtest.net" |
| HOMEPAGE="https://github.com/sivel/speedtest-cli" |
| SRC_URI="https://github.com/sivel/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" |
| |
| LICENSE="Apache-2.0" |
| SLOT="0" |
| KEYWORDS="-* amd64 arm64 ~x86" |
| |
| DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" |
| RDEPEND="${DEPEND}" |
| |
| PATCHES=( "${FILESDIR}/${PN}-2.1.3-json-serverlist.patch" ) |
| |
| python_install_all() { |
| doman ${PN}.1 |
| distutils-r1_python_install_all |
| } |